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ANIMATING SHAPES 
AND USING MASKS 

 
Lesson Overview 

In this lesson, you’ll learn how to do the following: 

• Animate shapes with shape tweens 

• Use shape hints to refine shape tweens 

• Shape tween gradient fills 

• View onion skin outlines 

• Apply easing to shape tweens 

• Create and use masks 

• Understand mask limitations 

• Animate the Mask and Masked layers 

This lesson will take about one hour to complete. Please log in to your 
account on peachpit.com to download the lesson files for this chapter, or 
go to the Getting Started section at the beginning of this book and follow 
the instructions under “Accessing the Lesson Files and Web Edition.” 
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You can easily morph—create organic changes in 
shape—with shape tweens . Masks provide a way to 
selectively show only parts of a layer . Together, they 
allow you to add more sophisticated effects to your 
animations . 
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● Note If you have not 
already downloaded 
the project files for 
this lesson to your 
computer from your 
Account page, make 
sure to do so now . See 
“Getting Started” at the 
beginning of the book . 

Getting Started 
You’ll start the lesson by viewing the animated logo that you’ll create as you learn 
about shape tweens and masks in Adobe Animate CC. 

1 Double-click the 08End.html file in the Lesson08/08End folder to play the 
animation in a browser. Your browser will need Flash Player to play the 
animation. Visit https://get.adobe.com/flashplayer/ for more information on 
installing and enabling Flash Player in your browser. 

 
 

The project is an animation of a flame flickering at the top of a fictional 
company name. Not only does the shape of the flame change constantly, but 
so does the radial gradient fill inside the flame. A linear gradient sweeps across 
the letters of the company name from left to right. In this lesson, you’ll animate 
both the flame and the colors that move across the letters. 

2 Close your browser. Double-click the 08Start.fla file in the Lesson08/08Start 
folder to open the initial project file in Animate. 

3 Choose File > Save As. Name the file 08_workingcopy.fla and save it in the 
08Start folder. Saving a working copy ensures that the original start file will be 
available if you want to start  over. 

 
Animating Shapes 
In the previous lessons, you learned to create animations with symbol instances. 
You could animate the motion, scale, rotation, color effect, or filters applied to 
symbol instances. However, you couldn’t animate the actual contours of a graphic. 
For example, creating an animation of the undulating surface of the ocean or the 
slithering motion of a snake’s body is difficult—if not impossible—with motion or 
classic tweens. To do something more organic, you have to use shape tweening. 

Shape tweening is a technique for interpolating stroke and fill changes between 
different keyframes. Shape tweens make it possible to smoothly morph one shape 
into another. Any kind of animation that requires the stroke or fill of a shape to 
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change—for example, animation of clouds, water, or fire—is a perfect candidate for 
shape tweening. 

Because shape tweening applies only to shapes, you can’t use groups, symbol 
instances, or bitmap images. 

 
Understanding the Project File 
The 08Start.fla file is an ActionScript 3.0 document that contains most of the 
graphics already completed and organized in different layers. However, the file is 
static, and you’ll add the animation. 

The text layer is at the very top and contains the company name, “Firestarter.” The 
flame layer contains the flame, and the bottom layer, called glow, contains a radial 
gradient to provide a soft glow. 

 

There are no assets in the library. 

 
Creating a Shape Tween 
To create the flickering flame effect, you’ll animate the undulating changes in a 
flame’s typical teardrop shape. You’ll rely on shape tweening to handle the smooth 
morphing from one shape to the next, as well as the gradual shifts in color. A shape 
tween requires at least two keyframes on the same layer. The beginning keyframe 
contains a shape drawn with the drawing tools in Animate or imported from Adobe 
Illustrator. The ending keyframe also contains a shape. A shape tween interpolates 
the smooth changes between the beginning keyframe and the end keyframe. 

Establish keyframes containing different shapes 
In the following steps, you’ll animate the flame that will sit on top of the 
company name. 

1     Select frame 40 for all three layers. 
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2 Choose Insert > Timeline > Frame (F5). 

Frames are added to all three layers up to frame 40 to define the overall length 
of the animation. 

 

3 Lock the text layer and the glow layer. This prevents you from accidentally 
selecting or moving the graphics in those layers. 

4 After making sure that none of the frames are selected, right-click frame 40 
in the flame layer and select Insert Keyframe, or choose Insert > Timeline > 
Keyframe (F6). The contents of the previous keyframe in frame 1 are copied into 
the new keyframe. 

You now have two keyframes on the Timeline in the flame layer, at frame 1 and 
at frame 40. Next, you’ll change the shape of the flame in the end keyframe. 

 

5 Select the Selection tool. 

6 Click away from the shape to deselect it. Move your cursor close to the outlines 
of the shape, and drag the contours of the flame to make the flame skinnier. 
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The beginning keyframe and the end keyframe now contain different shapes—a 
fat flame in the beginning keyframe, and a skinny flame in the end keyframe in 
frame 40. 

Apply the shape tween 
Next, you’ll apply a shape tween between the keyframes to create the smooth 
transitions 

1 Click any frame between the beginning keyframe and the end keyframe in the 
flame layer. 

2 Right-click, and choose Create Shape Tween. Or choose Shape Tween from the 
Insert menu. 

 
 
 
 
 
 
 
● Note Don’t worry 
if your flame doesn’t 
morph exactly the way 
you want it to . Small 
changes between 
keyframes work 
best . Your flame may 
rotate while going 
from the first shape 
to the second . You’ll 
have a chance later in 
this lesson to refine 
the shape tweening 
with shape hints . 

 
 
 

Animate applies a shape tween between the two keyframes, which is indicated 
by a black forward-pointing arrow and a green fill in the tween span. 

 

3 Watch your animation by choosing Control > Play (Enter/Return) or by clicking 
the Play button at the bottom of the Timeline. 
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You have created a smooth animation between the keyframes in the flame layer, 
morphing the shape of the first flame into the shape of the second flame. 

 

 
 

Changing the Pace 
The keyframes of a shape tween can be easily moved along the Timeline in order to 
change the timing or pacing of the animation. 

Moving a keyframe 
The flame slowly transforms from one shape to another over a period of 40 frames. 
If you want the flame to make the shape change more rapidly, you need to move the 
keyframes closer together. 

1 Select the last keyframe of the shape tween in the flame layer. 
 

 

2 Make sure the box icon appears near your cursor. Drag the last keyframe to 
frame 6. 
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Blend types 
In the Properties panel, you can modify your shape tween by choosing either the 
Distributive or the Angular option for Blend . These two options determine how 
Animate makes the interpolations to change the shapes from one keyframe to 
the next . 

 
 
 
 
 
 
 
 
 
 

The Distributive option is the default and works well for most cases . It creates ani- 
mations in which the intermediate shapes are smoother . 

Use the Angular blend if your shapes have many points and straight lines . Animate 
attempts to preserve apparent corners and lines in the intermediate shapes . 
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The shape tween shortens. 
 

 

3    Press Enter/Return to play your animation. 

The flame flickers quickly, and then remains static until frame 40. 
 
Adding More Shape Tweens 
You can add shape tweens by creating more keyframes. Each shape tween simply 
requires two keyframes to define its beginning state and its end state. 

Insert additional keyframes 
You want the flame to continually change shape, just like a real flame would. You’ll 
add more keyframes throughout the animation and apply shape tweens between all 
the keyframes. 

1 Right-click frame 17 in the flame layer and choose Insert Keyframe. Or choose 
Insert > Timeline > Keyframe (F6). 

The contents of the previous keyframe are copied into the second keyframe. 
 

 

2 Right-click frame 22 in the flame layer and choose Insert Keyframe (F6). 

The contents of the previous keyframe are copied into the new keyframe. 

 

3 Continue inserting keyframes at frames 27, 33, and 40. 
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Your Timeline now has seven keyframes in the flame layer, with a shape tween 
between the first and second keyframes. 

4 Move the red playhead to frame 17. 
 

 

5 Select the Selection tool. 

6 Click away from the shape to deselect it. Drag the contours of the flame to 
create another variation in its shape. You can make the base thicker, or change 
the curvature of the tip to make it lean left or right. 

 

 

7 Modify the flame shapes in each of the newly inserted keyframes to create 
subtle variations. 
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Extending the shape tweens 
Your next step is to extend the shape tween so that the flame morphs from one 
shape to the next. 

1 Right-click any frame between the second and third keyframes, and choose 
Create Shape Tween. Or choose Insert > Shape Tween. 

 

 

A black forward-pointing arrow on a green background appears between the 
two keyframes, showing that you’ve applied a shape tween. 

 

2 Continue to insert shape tweens between all the keyframes. 

You should have six shape tweens in the flame   layer. 

 

3 Press Enter/Return to watch the animation play. 
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● Note Try this 
shortcut: select a range 
of frames that cover 
multiple keyframes, 
right-click, and choose 
Create Shape Tween to 
apply a shape tween 
across all keyframes . 

Your flame flickers back and forth for the duration of the animation. Depending 
on how extensive your modifications to the flame have been, your flame may 
undergo some weird contortions between keyframes—for example, flipping or 
rotating unpredictably. Don’t worry! You’ll have a chance later in the lesson to 
refine your animation with shape hints. 

 

 
 
 

Creating a Looping Animation 
Your flame should flicker back and forth continuously for as long as the logo is 
onscreen. You can create a seamless loop by making the first and last keyframe 
identical and putting the animation inside a movie clip symbol. A movie clip time- 
line loops continuously, independently of the main Timeline. 

Duplicating keyframes 
Make the first keyframe identical to the last keyframe by duplicating its contents. 

1 Right-click the first keyframe on the flame layer and select Copy Frames. Or 
choose Edit > Timeline > Copy  Frames. 

 

The contents of the first keyframe are placed on your clipboard. 
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Broken tweens 
Every shape tween needs a beginning and an end keyframe with a shape inside 
each . If the last keyframe of a shape tween is missing, Animate shows the broken 
tween as a dotted black line (rather than a solid arrow) . 

Broken shape tween 
 
 
 
 
 
 
 

In this example, insert a keyframe at frame 40 to fix the tween . 
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2 Right-click the last keyframe on the flame layer and select Paste Frames. Or 
choose Edit > Timeline > Paste Frames. 

● Note The Loop 
Playback option loops 
only in the Animate CC 
authoring environment, 
and not when it is 
published . 

 

 
 

The first and last keyframes now contain identical flame shapes. 

Previewing the loop 
Use the Loop button at the bottom of the Timeline to preview your animation. 

1 Click the Loop button at the bottom of the Timeline, or choose Control > Loop 
Playback (Alt+Shift+L/Option+Shift+L) to enable continuous playback when 
you play the movie. 

� Tip You can quickly 
duplicate keyframes 
by first selecting a 
keyframe and then 
Alt/Option-dragging 
the keyframe to a new 
position . 

 

 
 

Markers appear on the Timeline header indicating the range of frames that loop 
during playback. Next, adjust the markers to extend the loop to include the 
entire movie. 

2 Extend the markers to include all the frames on your Timeline (frames 1 
through 40), or click the Modify Markers button and choose Marker Range All. 

 
 
 
 
 
 
 

Modify Markers 
 

 

3 Press Enter/Return to test the animation. 

The flame animation plays and loops continuously. Click the Pause button or 
press Enter/Return again to stop the animation. Deselect the Loop button at the 
bottom of the Timeline to hide the markers and end the loop playback mode. 
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Inserting the animation into a movie clip 
When your animation plays in a movie clip symbol, the animation loops 
automatically. 

1 Select all the frames on the flame layer, right-click, and choose Cut Frames. Or 
choose Edit > Timeline > Cut Frames. 

 

 

The keyframes and shape tweens are removed from the Timeline and placed on 
the clipboard. 

2 Choose Insert > New Symbol (Ctrl+F8/Command+F8). 

The Create New Symbol dialog box appears. 

3 Enter flame as the name of the symbol, and choose Movie Clip as the Type. 
Click OK. 

 

 

A new movie clip symbol is created and opens in symbol-editing mode. 

4 Right-click the first frame on your movie clip timeline and select Paste Frames. 
Or choose Edit > Timeline > Paste Frames. 

 

 

The flame animation from the main Timeline is pasted into your movie clip 
symbol’s timeline. 
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5 Click the Scene 1 button on the Edit bar at the top of the Stage, or choose Edit > 
Edit Document (Ctrl+E/Command+E). 

You exit symbol-editing mode and return to the main Timeline. 

6 Select the flame layer, which is currently empty. Drag your newly created flame 
movie clip symbol from the Library panel to the Stage. 

An instance of the flame movie clip symbol appears on the Stage. 
 

 

7 Choose Control > Test (Ctrl+Enter/Command+Return). 

Animate exports the SWF in a new window, where you can preview the 
animation. The flame flickers continuously in a seamless loop. 
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Shape tweening with 
variable width strokes 
Any aspect of a shape can be shape tweened, including variable widths of a shape’s 
stroke . In Lesson 2, you learned to use the Width tool to create lines with thick 
and thin variations for more expressive graphics . You can change the width of the 
strokes in different keyframes, and when you apply a shape tween between those 
keyframes, Animate creates smooth interpolations of those stroke widths . 

Considering the ability to animate the thickness of a shape’s stroke, the contours 
of the stroke itself, and the inside fill of a shape, the creative possibilities are nearly 
limitless . 
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� Tip Shape hints 
should be placed on the 
edges of shapes . 

Using Shape Hints 
Animate CC creates the smooth transitions between keyframes of your shape 
tween, but sometimes the results are unpredictable. Your shapes may go through 
strange contortions, flips, and rotations to get from one keyframe to another. You 
may like the effect, but more often than not you’ll want to maintain control of the 
transformations. Using shape hints can help refine the shape changes. 

Shape hints force Animate to map points on the start shape to corresponding 
points on the end shape. By placing multiple shape hints, you can more precisely 
control how a shape tween appears. 

Adding shape hints 
Now you’ll add shape hints to the shape of the flame to modify the way it morphs 
from one shape to the next. 

1 Double-click the flame movie clip symbol in the library to enter symbol-editing 
mode. Select the first keyframe of the shape tween in the flame layer. 

 

 
 

2   Choose Modify > Shape > Add Shape Hint (Ctrl+Shift+H/Command+Shift+H). 
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A red-circled letter “a” appears on the Stage. The circled letter represents the 
first shape hint. 

 

3 Select the Selection tool and make sure that Snap To Objects is selected. 

The magnet icon at the bottom of the Tools panel should be selected. Snap To 
Objects ensures that objects snap to each other when being moved or modified. 

4 Drag the circled letter to the tip of the flame. 
 

 

5 Choose Modify > Shape > Add Shape Hint again to create a second shape hint. 

A red-circled “b” appears on the Stage. 
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6 Drag the “b” shape hint to the bottom of the flame shape. 
 

 

You have two shape hints mapped to different points on the shape in the first 
keyframe. 

7 Select the next keyframe of the flame layer (frame 6). 

A corresponding red-circled “b” appears on the Stage, hiding an “a” shape hint 
that is directly under it. 

 

8 Drag the circled letters to corresponding points on the shape in the second 
keyframe. The “a” hint goes on the top of the flame, and the “b” hint goes on the 
bottom of the flame. 

The shape hints turn green, indicating that you’ve correctly placed them. 
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9 Select the first keyframe. 

Note that the initial shape hints have turned yellow, 
indicating that they are correctly placed. When 
placed properly, the shape hints in the beginning 
keyframe turn yellow and those in the ending 
keyframe turn green. 

10 Scrub the playhead through the first shape tween on 
the Timeline to see the effect of the shape hints on 
the shape tween. 

The shape hints force the tip of the flame in the first 
keyframe to map to the tip of the flame in the second 
keyframe and force the bottoms to map to each 
other. This restricts the transformations. 

To demonstrate the value of shape hints, you can 
deliberately create a mess of your shape tweens. In 
the end keyframe, put the “b” hint at the top of the 
flame and the “a” hint at the bottom. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Tip You can add a 
maximum of 26 shape 
hints to any shape 
tween . Be sure to add 
them consistently 
in a clockwise or 
counterclockwise 
direction for best 
results . 

 
 
 
 

Beginning keyframe Ending keyframe 

 
Animate forces the tip of the flame to tween to the bottom of the flame, and vice 
versa. The result is a strange flipping motion as Animate tries to make the transfor- 
mation. Put the “a” back at the top and the “b” back at the bottom after you’re done 
experimenting. 
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Removing shape hints 
If you’ve added too many shape hints, you can easily delete the unnecessary ones. 
Removing a shape hint in one keyframe will remove its corresponding shape hint in 
the other keyframe. 

• Drag an individual shape hint entirely off the Stage and pasteboard. 

• Choose Modify > Shape > Remove All Hints to delete all the shape hints. 
Only the content in the keyframes of a shape tween is displayed fully rendered. 
All other frames are shown as outlines. To see all frames fully rendered, use onion 
skinning, as described in the next exercise. 

 
Previewing Animations with Onion Skinning 
It’s sometimes useful to see how your shapes are changing from one keyframe to 
another on the Stage all at once. Seeing how the shapes gradually change lets you 
make smarter adjustments to your animation. You can do so using the onion skin- 
ning option, available at the bottom of the Timeline. 

Onion skinning shows the contents of the frames before and after the currently 
selected frame. 

The term “onion skin” comes from the world of traditional hand-drawn anima- 
tion, in which animators draw on thin, semitransparent tracing paper known as 
onionskin. A light box shines a light behind the drawings to allow them to be seen 
through several sheets. When creating an action sequence, animators flip back and 
forth quickly between drawings held between their fingers. This allows them to see 
how the drawings smoothly connect to each other. 

Turning on onion skinning 
There are two modes for onion skinning: Onion Skin and Onion Skin Outlines. 
Although both show previous and future frames, Onion Skin displays graphics fully 
rendered, whereas Onion Skin Outlines shows only the outlines of your graphics. 
In this task, you’ll use Onion Skin Outlines. 

1    Click the Onion Skin Outlines button at the bottom of the Timeline. 
 

 

Animate shows several outlines of the flame, with the currently selected frame 
in red. The previous two frames are shown in blue, and the future two frames 
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are shown in green. The outlines of the flame fade the farther away they are 
from the current frame. 

 

On the Timeline, Animate displays markers to bracket your currently selected 
frame. The blue-marked bracket (to the left of the playhead) indicates how 
many previous frames are shown on the Stage, and the green-marked bracket 
(to the right of the playhead) indicates how many future frames are shown. 

 

2 Move the playhead to a different frame. 

Animate keeps the markers around the playhead no matter where you move it, 
always showing the same number of frames behind and ahead. 

3 Click the Onion Skin button at the bottom of the Timeline. 
 

 

Onion skinning switches from Outlines mode to the standard Onion Skin mode, 
showing the onion skins of your flame fully rendered. The flames from previous 
frames are tinted blue, and the flames from future frames are tinted green. 

 
 
 
 
 
 

ADOBE ANIMATE CC CLASSROOM IN A BOOK (2018 RELEASE)   283 

Past frames 
Current frame 

Future frames 
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� Tip You can even 
scrub the playhead 
back and forth along 
the Timeline to see 
the ghostly images 
of the onion skins 
moving along with the 
animation . You cannot 
see onion skins during 
normal playback, 
however . 

 
 
 
 
 
 
 
 

Adjusting the markers 
You can move either marker to show more or fewer onion skin frames. 

• Drag the blue marker to adjust the number of past onion skin frames shown. 
 

 

• Drag the green marker to adjust the number of future frames displayed. 

• Hold down the Ctrl/Command key while dragging either marker to move the 
past and future markers in equal amounts. 

• Hold down the Shift key while dragging either marker to move the onion skin 
range to a different spot on the Timeline (as long as it still encompasses the 
playhead). 

• Click the Modify Markers menu button to select a preset marker option. For 
example, you can choose Marker Range 2 or Marker Range 5 to have the 
markers show two or five frames, respectively, in front of and behind the 
current frame. 
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Customizing onion skin colors 
If you don’t like the green and blue color coding of previous and future frames, you 
can change them in the preferences. 

1 Choose Edit > Preferences (Windows) or Animate CC > Preferences (Mac). 

The Preferences dialog box appears. 

2 In the Onion Skin Color section, click the color boxes for Past, Present, or 
Future to choose new colors. 

3 Click OK. Deselect the Onion Skin or Onion Skin Outlines button to return to 
the default view. 

 

 
 

Animating Color 
Shape tweens interpolate all aspects of a shape, which means that both the stroke 
and fill of a shape can be tweened. So far, you’ve modified the stroke, or outlines, 
of the flame. In the next section, you’ll modify the fill so that the color gradi- 
ent can change—perhaps glow brighter and more intensely at some points in the 
animation. 
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Adjusting the gradient fills 
Use the Gradient Transform tool to change the way the color gradient is applied to 
a shape, and use the Color panel to change the actual colors used in a gradient. 

1 If you’re not already in symbol-editing mode for your flame symbol, double- 
click the flame movie clip symbol in the library to edit it. 

2 Select the second keyframe on the flame layer (frame 6). 

3 Select the Gradient Transform tool, which is grouped with the Free Transform 
tool in the Tools panel. 

The control points for the Gradient Transform tool appear on the gradient fill of 
the flame. The various control points allow you to stretch, rotate, and move the 
focal point of the gradient within the fill. 

 
 
 
 
 
 
 
 
 
 
 
 
 

Focal point 
 
 

Center point 

 
 

Width 
 

 
Size 

 
 

Rotation 
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4 Use the control points to tighten the color gradient into the base of the flame. 
Reduce the gradient’s size, make it wider, position it lower on the flame, and 
move the focal point (represented by a tiny triangle) of the gradient to one side. 

 

 

Your flame’s orange core appears lower and more intense because the colors are 
distributed in a smaller area. 

5 Move the playhead along the Timeline between the first and second keyframe. 

The shape tween automatically animates the colors inside the flame as well as its 
contours. 

6 Select the third keyframe on the flame layer (frame 17). In this frame, you’ll 
adjust the actual color of the gradient. 
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7 Select the Selection tool and click the fill of the flame on the Stage. 

8 Open the Color panel (Window > Color). 

The Color panel appears, showing you the 
gradient colors of the selected fill. 

9 Click the inner color marker, which is currently 
yellow. 

10 Change the color to a hot pink (#F109EE). 

The center color of the gradient turns pink. 

 

11 Move the playhead along the Timeline between the second and third keyframes. 

● Note Shape tweens 
can smoothly animate 
solid colors or color 
gradients, but they 
can’t animate between 
different types of 
gradients . For example, 
you can’t shape tween 
a linear gradient into a 
radial gradient . 

 
 
 
 
 
 
 
 

The shape tween automatically animates the center color in the gradient from 
yellow to pink. Experiment with the other keyframes by modifying the gradient 
fill and see what kinds of interesting effects you can apply to your flickering flame. 
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Creating and Using Masks 
Masking is a way of selectively hiding and displaying content on a layer. It enables 
you to control the content that your audience sees. For example, you can make a 
circular mask and allow your audience to see only through the circular area so that 
you get a keyhole or spotlight effect. In Animate, you put a mask on one layer and 
the masked content in a layer below it. 

For the animated logo you’re creating in this lesson, you’ll make the text a little 
more visually interesting by using the text itself as a mask. 

Define the mask layer 
You’ll create from the “Fire starter” text a mask that will reveal an image of a fire 
beneath it. 

1 Return to the main Timeline. Unlock the text layer. Double-click the icon 
in front of the text layer name, or select the text layer and choose Modify > 
Timeline > Layer Properties. 

The Layer Properties dialog box appears. 
 

 

2 Select Mask and click OK. 
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● Note Animate does 
not recognize different 
Alpha levels in a mask 
created on a timeline, 
so a semitransparent 
fill in the mask layer 
has the same effect 
as an opaque fill, and 
edges will always be 
hard . However, in 
an ActionScript 3 .0 
document, you can 
use ActionScript code 
to dynamically create 
masks that will allow 
transparencies . 

 
 
� Tip Masks do not 
recognize strokes, so 
use only fills in the mask 
layer . Text created with 
the Text tool also works 
as a mask . 

The text layer becomes a mask layer, indicated by the mask icon in front of the 
layer name. Anything in this layer will act as a mask for a masked layer below it. 

 

 

For this lesson, we’re using the text already in place as the mask, but the mask    
can be any filled shape. The color of the fill doesn’t matter. What’s important to 
Animate are the size, location, and contours of the shape. The shape will be the 
“peephole” through which you’ll see the content on the layer below. You can use 
any of the drawing or text tools to create the fill for your mask. 

Create the masked layer 
The masked layer is always under the mask layer. 

1 Click the New Layer button, or choose Insert > Timeline > Layer. 

A new layer appears. 

2 Rename the layer fiery effect. 
 

 
 

3 Drag the fiery effect layer under the mask layer (named “text”) and a little to the 
right so that it becomes indented. 

The fiery effect layer becomes a masked layer, paired with the mask layer above 
it. Any content in the masked layer will be masked by the layer above it. 

 

4 Choose File > Import > Import To Stage, and select fire.jpg from the 08Start 
folder. 
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The bitmap image of fire appears on the Stage, and the words appear over the 
image. 

 
 
 

� Tip You can also 
double-click a normal 
layer under a mask 
layer, or choose 
Modify > Timeline > 
Layer Properties, and 
select Masked to modify 
the layer into a masked 
layer . 

 
 
 
 

 
See the effects of the mask 
To see the effects of the mask layer on its masked layer, lock both layers. 

1 Click the Lock option for both the text layer and the fiery effect layer. 
 

 

Both mask and masked layers become locked. The shapes of the letters in the 
mask layer reveal parts of the image in the masked layer. 

 

2 Choose Control > Test. 

As the flame flickers above the text, the letters reveal the fiery texture in the 
layer below it. 

● Note You can have 
multiple masked layers 
under a single mask 
layer . 
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Animating the Mask and Masked Layers 
The letters of your animated logo have more drama now that you’ve created a mask 
with an image of fire behind it. However, the client for this fictional project now 
demands that it have even more punch. Although she likes the look of the fiery let- 
ters, she wants an animated effect. 

Fortunately, you can include animations in either the mask or the masked layer. You 
can create an animation in the mask layer if you want the mask itself to move or 
expand to show different parts of the masked layer. Or you can create an anima- 
tion in the masked layer if you want the content to move under a mask, like scenery 
whizzing by a train window. 

Adding a tween to the masked layer 
To make the logo more compelling for your client, you’ll add a shape tween to the 
masked layer. The shape tween will move a glow from left to right for a portion of 
the movie under the letters. 

1 Unlock both the text layer and the fiery effect layer. 

The effects of the mask and masked layer are no longer visible, but their 
contents are now editable. 

2 Delete the bitmap image of the fire in the fiery effect layer. 

3 Choose the Rectangle tool and open the Color panel (Window > Color). 

4 In the Color panel, make sure Fill Color is selected and choose Linear Gradient 
from the Color Type menu. 
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Traditional masks 
It might seem counterintuitive that the shapes in the mask layer reveal, rather than 
hide, the content in the masked layer . However, that’s exactly how a traditional mask 
in photography or painting works . When a painter uses a mask, the mask protects 
the painting from paint splatters . When a photographer uses a mask in the dark- 
room, the mask protects the photosensitive paper from the light, to prevent those 
areas from getting any darker . So thinking of a mask as something that protects a 
lower, masked layer is a good way to remember which areas are hidden and which 
are revealed . 
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5 Create a gradient that starts with red on the far left (#FF0000), goes to yellow in 
the middle (#FFFC00), and becomes red again on the far right (#FF0000). Make 
sure your Alpha settings are at 100% so that the colors are not transparent. 

 

 

6 Create a rectangle in the fiery effect layer that encompasses the letters in the 
text layer. 

 

 

7 Choose the Gradient Transform tool, and click the fill of your rectangle to select it. 

The control handles for the Gradient Transform tool appear on the fill of the 
rectangle. We’ll use this tool to position the gradient off the Stage so it can make 
a dramatic entrance. 
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8 Drag the center point of the gradient so that the yellow color appears on the far 
left side of the Stage. 

 

 

The yellow glow will enter from the left and move to the right. 

9 Right-click frame 20 in the fiery effect layer and choose Insert Keyframe (F6). 

The contents of the previous keyframe are copied into the new keyframe. 

 

10 Right-click the last frame (frame 40) in the fiery effect layer and choose Insert 
Keyframe (F6). 

The contents of the keyframe at frame 20 are copied into the new keyframe. You 
now have three keyframes in the fiery effect layer. 

 

11 Make sure that your playhead is still in the last frame (frame 40). 
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12 Drag the center point of the gradient far enough to the right so that the yellow 
color is just barely visible on the right side of the Stage. 

 

 

13 Right-click anywhere on the Timeline between the second and third keyframe 
in the fiery effect layer, and select Create Shape Tween. Or, from the top menu, 
choose Insert > Shape Tween. 

The color gradient is shape tweened so that the yellow glow moves within the 
fill of the rectangle from left to right. 

 

14 Watch your animation by choosing Control > Test. 
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While the flame burns above the letters, a soft yellow glow flashes across the 
letters. 

 
 
 
 
 
● Note The Motion 
Editor, which is the 
advanced panel 
integrated into the 
Timeline that provides 
different ease types, is 
not available for shape 
tweens . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
● Note As with classic 
tweens, you can apply 
more advanced eases 
or even custom eases . 
Click the Classic Ease 
button to access the 
additional ease options . 

Easing a Shape Tween 
Eases help your animation bear a sense of weight by enabling you to add an accel- 
eration or deceleration component to its motion. 

You add an ease to a shape tween in the Properties panel. Ease values range from 
−100, which indicates an ease-in, to 100, which indicates an ease-out. An ease- 
in makes the motion start off slowly. An ease-out slows down the motion as it 
approaches its end keyframe. 

Adding an ease-in 
You’ll make the glow that flashes across the letters of the logo begin slowly and then 
pick up speed. The ease-in will help viewers take notice of the animation before it 
proceeds. 

1 Click anywhere inside the shape tween in the fiery effect layer. 

2 In the Properties panel, enter -100 for the Ease value. 
 

Animate applies an ease-in effect to the shape tween. 

3 Make sure your mask and masked layers are locked, and choose Control > Test 
to test your movie. 

The soft yellow glow flashes across the letters, starting off slowly and then 
adding a little more sophistication to the entire animation. 
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